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SpiffyCharts and the SpiffyCharts Manual are copyright, 2000-2017, all rights reserved.

Warranty
There is no warranty, expressed or implied. You use SpiffyCharts entirely at your own risk. All complex
software has defects and SpiffyCharts is no exception. Also, technical analysis software can be misapplied,
leading you to incorrect conclusions. Always “paper trade” any new system you develop before committing
real money in the securities markets.

New versions of SpiffyCharts may be downloaded from the website at www.spiffycharts.com
Contact us at:
info@spiffycharts.com or
bugs@spiffycharts.com or
Your Email subject must include SPIFFY or our spam filter will delete it.
SpiffyCharts is a trademark of Investors’ Technical Services.
Oct 25, 2017
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SpiffyCharts Quick-Start
SpiffyCharts 2.8 is a Macintosh Program!
Out apologies to Windows and Linux users, but the disparate menu and window handling designs forced us to
make too many compromises, so those versions were terminated.
In order to use this program you must have Internet access and have it configured properly. The latest version
of Mac OSX is recommended.

Warning
SpiffyCharts is for people who like to think and learn. If you want software that thinks for you - well good
luck with that!

Once over Lightly
SpiffyCharts is a general purpose charting program which will download daily update data, maintain your data
files and chart and print plots. You can use the many built-in indicators, write your own indicators or input
those you find in trading magazines. You can backtest and optimize trading systems. SpiffyCharts will also
display reports for your personal portfolios, and scan your data files indicating trading actions to be taken
tomorrow.

Program Installation
Download the compressed Disk Image and open it on you desktop. Then drag the Spiffy Folder to any place
you want it. We recommend you drop it into the Applications folder. All required files, preferences etc. reside
in the Spiffy Folder and no changes are made anywhere on your computer. Installation is now complete except
for entering your name and activation code. If desired you can make a shortcut to the program and leave the
shortcut on your desktop or place it in the Dock.
To uninstall SpiffyCharts just drag the Spiffy folder to the trash.

Registration
You must enter your name and registration code before you can use SpiffyCharts. Register through the
SpiffyCharts web site. Registration is free.
When you register you will receive an email with your name and registration number.
When you first start SpiffyCharts a window will be opened into which you type your name and registration
number. Your license number will not work unless you enter your name exactly as it appears in your email.
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SpiffyCharts
SpiffyCharts supports the three functions required of a general purpose charting and trading program.
1) Downloading security data, editing and correcting data, when needed.
2) Backtesting and system development.
3) Portfolio tracking and scanning for tomorrow’s trades.
All functions are accessed through the menus.
SpiffyCharts does not support the use of intra-day data.
The screen shot below of the menu bar and the File menu shows the normal Macintosh functions as well as
access to our very simple macro setup and access to allow restoration of recently used charts.

Downloading Data
SpiffyCharts supports two commercial data vendors directly and also data downloaded from
Finance.Yahoo.Com, the free data from EODdata, a free SP500 source and other text data sources.
Requirements for text data sources are detailed in the Tech Manual.
The Data menu gives access to all of the functions required to download and maintain your data.
If you download data from Yahoo or from a web page the file will go into your Downloads folder. Select
Post Other from the Data->Manual Post SpiffyCharts will dip into the Downloads folder, move your new
input files and then will post the data to your data files, creating files and folders as required. There is a
fifteen minute limit imposed on this function. Older files in the Downloads folder will not be recognized.

Account Setup
Choose the data service you expect to use from the Data menu item, and then select SetUp. A dialog will
open allowing you to enter the required user identification information.

Portfolio Setup
The SetUp item also allows you to define the items you wish to download on a daily basis.
The portfolio setup dialog is specific to each data service. The entries are generally easy to understand, and
most dialogs have one or more buttons labeled simple “?” When the mouse cursor passes over such a button
the program displays helpful information.
Detailed examples are given in the technical manual.
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During the “Post” operation SpiffyCharts takes the incoming data and converts it to the correct format and
appends it to your data files. If you should accidentally download an extra date or two SpiffyCharts will use
the extra new data to overwrite old data. You will not get any extraneous data in your files.

Get Data
When you select Get Data SpiffyCharts will connect to your data vendor, download the data and will then
post it to your data files. You will be informed of progress through messages written to the Messages Window.

Edit Data File
When you select Edit Data file you will be allowed to browse through your data folder to select a data file,
which is then opened in a window such as the one below.

The edit functions are controlled by the small buttons. Put the cursor on a button and leave it for a few
seconds and a small window will open and describe the function.
Details are given in the technical manual.
One of the functions of the Edit Data window is Export, which reformats the data in a way which may be
useful in other programs.

Charting
The File>Open.. menu allows you to select any of the defined “Models.” You will then be allowed to select
any data file, which will be opened, the ‘studies’ calculated and plotted.
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There are two ways that you can modify the “studies” lines on a chart.
A) Using the formula Bar - very flexible - almost unlimited possibilities.
B) Using the popup menu at the lower left of the chart window - maybe easier to use.

Adding Studies though the Dialog
If you choose Add Study you will be presented with a dialog that allows selection of a variety of studies..
After you make the necessary selections and inputs your study will be added to your chart.

Formula Bar
You can also add studies to the chart by using the Formula Bar. This is more powerful and more complex than
using the dialog. Use whichever method you want or need.
When you move the cursor over the top of the data display and into the box labeled “N” the mouse cursor will
change to a plus symbol. Click the mouse button and an empty Formula Bar will be displayed.
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Enter the name for your new study in the title box and the formula in the formula box. Check on/off plotting
and set the other plotting choices using the popup menus. Details of using the Formula Bar are given in the
Studies Appendix.
If you move the mouse cursor over the title at the top of a study column the cursor will change to a “Disclosure
Triangle.” Click the button and you will see the formula used to create the column. Observing the formulas
above a number of the columns will aid you in understanding how the formula bar works.
When you have entered a new formula or edited an old formula two buttons will appear to the left of the Title
Box. If you click on the X box then the formula will revert to its original state. If you click on the check mark
SpiffyCharts will analyze your input and if it appears acceptable the program will create a new column of data
and will plot it according to the choices made in the plotting commands.
When entering a formula you may place spaces anywhere you wish. Input is generally not case sensitive.
Column titles must be 3 or more letters starting with a letter (a-z) and without any math symbols.
A complete list of formula commands is given in the Technical manual.
When the formula for an existing column is displayed there is a button shown labeled Delete. This button
allows you to delete any column you have created. This is the only way to remove a column.

Chart Display
You will note several icons near the top right of the
chart. The “CloseDoor” and “OpenDoor” icons will
change the number of bars being displayed. The
“candle flame” icon allows you to vary the day by day
bar appearance. The short line icon and the AB icon
allow you to annotate your chart for printing or export
into other programs.
Touch <Command> C and the chart will be copied onto
the Mac’s clipboard.
You can also vary the number of bars being displayed
in the chart window by using your <UpArrow> and
<DownArrow> keys. If you go below two pixels per
bar the bar chart will be replaced by a line chart of closing prices. If you drop below one pixel per bar then
SpiffyCharts will “crunch” the data, displaying all available data across the chart, regardless of size.
You will also note one or two double headed arrows at the right of the chart. Slide a double arrow icon up or
down and release the mouse button and the split between chart and data or between price bars in indexes will
be modified
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Chart Cursor
If you hold down the mouse button while the cursor
is over the chart, the cursor will become a sharp
pointer, temporary cross hairs will be drawn across
the chart and a box will display the computed height
of the cursor. Data shown in the worksheet will be
scrolled to the date under the cursor.

Multiple Charts
SpiffyCharts can open any number of chart windows. Note that a chart is opened using a Trading Model, that
Model is read into memory and all charts opened with that Model are created and controlled by the
information held in the Model memory. Thus, if you have several charts opened using a single Model and you
edit any one of the charts then ALL CHARTS WILL BE UPDATED TO THE NEW CONFIGURATION.
When you close chart windows you will not be asked about saving changes until the last window using a
particular Model is closed. When the last window using a Model is closed its memory will be released.

BackTesting
Testing a set of rules and studies with old
data - backtesting - allows a trader to learn
their strengths and weaknesses and to
develop new trading methods. We refer to a
set of studies and rules as a Trading Model.
When you have a chart open and click on the
button labeled R at the top right of the chart
your will open the Rule Window for the
trading model. The rules can reference any
data in the worksheet as well as the three
“Model Vars.” You can define your own
variables within the rules, if needed. Your
rules can also access a large number of trade
information items.
Detailed information on the rules is given in the Technical manual, but note the following:
Each rule is separate and complete from all others.
The order in which rules are written is unimportant.
Any calculations are made just before the close of each bar.
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To backtest your model with the one data file shown in your chart, choose the menu item Test>TestCurrent
(or use <command> T>) Almost immediately you will get a report and daily equity chart and your original
chart will be redrawn with pale pink and pale green rectangles indicating periods when the model was long or
short.

Optimizing with SpiffyCharts
You can “Optimize” a trading model which is set up to use the Model Vars. Use the Rule Window Prefs tab
and to set your Model Vars tab select Test>Optimize Current. Please understand that your goal in
optimizing is not to get really great results, but to find ways to get consistently good results.
You can optimize up to three variables simultaneously. See the Technical manual for examples and details.

Testing and Optimizing with Lists
The Test menu has two items, Test List and Optimize List.
Lists are exactly what the name implies, lists of security symbols, generally all of the same type, and always
one symbol per line. By same type we mean all stocks, all mutual funds etc.
The Lists item will allow you to create or edit a List. There are several ways to edit a list. Dragging symbols
from a Report window is described in the next section. You can paste a list of securities that you copy from
any window, including the names of data files you copy from the desktop using your OS to select and copy.
There are three things that SpiffyCharts can do with a list of securities.
Backtest, Optimize and Scan (covered in the next section of this manual.)
Choose the Optimize List and you will get the dialog shown. In order to optimize your trading model must
be set up to use Model Vars.
One thing to note about testing and optimizing lists is that
all of the files in your list are opened simultaneously
and trade testing proceeds bar by bar for all files. i.e..
All files will be tested for a given day before
proceeding to the next day. SpiffyCharts will keep
track of the total capital committed for all open
positions and will block any new trades if such a trade
would cause total commitments to exceed available
capital. (The trade will be “ opened” with zero
positions.)
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SpiffyCharts Portfolios
The Portfolios show the most recent data for your securities.
They can also indicate the current value of your portfolio.

All Symbols
The All Symbols report shows data for all current securities in your data folder . The format for this report is
fixed, each line showing:
Symbol Date Open High Low Close Vol OpenInt PriorClose Name
Symbol is the data file name, the title which your data service uses.
Date is the most recent update for this security, in YYYYMMDD format.
Open, High, Low, Close are the most recent price data points. They will be shown as zero if no data is
available, as will Vol and OpenInt and Prior Close.
There is one column which you can edit: NAME. Some stock and mutual fund symbols may be difficult to
remember. For example you might want the NAME for the Symbol LUV to be SWA (Southwest Airlines.)
You can type in any reminder or name you want.
Reset
When you first open the AllSymbols report it will be empty. Touch the Reset button and SpiffyCharts will go
through your data folder and add all the securities it can find. Going through a few thousand data files will
take 5 to 10 seconds, depending mainly on the speed of your hard disk. Reset will also remove any securities
which have not been updated in the past month.
Your reports will be empty until you download some current data!
Trading Model
Each Report Window has a Trading Model popup menu will allow you to choose any of the Models you have
defined. Then when you double click on a symbol that symbol will be plotted using the chosen Trading
Model. This is also the model which would be used for scanning
Editing Security Names
The last entry on each line of the All Symbols window is the name of the security. These names are
automatically filled in by SpiffyCharts. If you wish to enter a name or wish to edit an old name you may do so
by clicking at the start of the name or the name space. A small pale yellow window will be drawn on top of
the old name. Edit any name shown in the yellow box. Hit <Return> or <Enter> to exit this editing function.
This name will be written to the file on disk.
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Personal Reports
Trading>New Portfolio will allow you to define your own reports. The New Report dialog will show a list of
possible items to be shown in your new report. You can select any set of items, in any order with the
exception that Symbol is always the first item.
You can select items from the left column and move them to the right column either by dragging or by double
clicking. Move items out of the right hand list by double clicking. After you have set the format and named
the report, hit the OK button you will see your new, empty report. (The name of the report will also be added
to the Reports popup menu.)

You populate your new report by dragging symbols from the AllSymbols list to your new report. Remove
symbols from the report by choosing with the mouse and then touching the <delete> key.
sTwo items in your new report may be edited: Shares and Total cost. Any information you enter for these two
items will be specific to this new report. If you create a second (third..) new report using some of the same
symbols as in your first personal report, the Shares and Cost information from the first report will not be
available in the other reports, i.e. the data in the Shares and Cost columns are specific to each of your personal
portfolios. When you enter information in these two columns the calculated columns CurVal and CurNet will
automatically be calculated.
You can also drag security symbols to or from one of your lists.
Reformat
Use the Reformat button to modify your report at any time. Information for items no longer displayed is not
lost. For example, assume you originally formatted your personal portfolio report so that you can enter
number of shares, cost etc, and that you then reformat so that Shares, Totcost, Curval and/or Curnet are
hidden. If you reformat again at a later time the hidden information will still be there but updated to reflect
chnages in prices.
Charting
Double Click on a symbol and that security will be charted using the model as set in the popup menu.
Delete
Hit the delete button and the report will be deleted.

Using the Scanner
A trader who is following a large number of stocks or commodities will find it very time consuming to review
each of them, one by one. Why not let the computer look through the lot quickly, scan them, and alert the
trader to any actions that appear to be required by the trader’s system. The actions indicated by the scanner
are not intended to be the absolute word, but must always be reviewed by the trader,
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The SpiffyCharts Scanner is accessed through one of your Report windows or via the Scan pop-up menu.
The Scan popup menu will allow you to scan a list or a folder.Within one of your report windows you can use
the pop-up menu in your report window to select your trading model, then punch the eye icon to start the
scanner.

Note that it is advisable to sort your Symbol list so that the A’s are at the top. To sort the Symbols just click on
the heading. If the order is reversed then click again. Sorting is required for proper operation of the indexing
window.

Model Setup for Scanning
Any reasonable trading model can be used by the scanner, but you should note the caveats listed below. The
more complex the model the more carefully you will need to scrutinize the scanner output.

Scanning Example
When you punch the eye icon SpiffyCharts will open each file in sequence. The file will be tested for three
things, length, missing data columns and up-to-date data. If the file fails any of these tests the file will be
closed and an error message will be given.
Files which are up to date and otherwise usable by the trading model you selected will be opened and your
trading model will be applied to determine your current position which will be used to generate the first line of
the Scanner report for each security. The Spiffy Scanner will then evaluate any rules that will be active
tomorrow. These rules will be used to generate one or more additional lines.
These results go to a window with two fields, a Symbols list which is an index to the full scan results shown in
the right field. You can print or copy-paste the results but they cannot be edited.
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Click on a symbol in the index list and the scan reports will be scrolled to display the results for the symbol
chosen. You can also type a symbol shown in the index to scroll to that portion of the scan results window.

Controlling the Scanner Index
You will note that the index does not list all of the securities which were scanned. The limited list allows
you to go directly to those securities which meet your selection criteria. It also controls printing.
You set the indexing criteria by opening the trading model through the Chart menu. Then in the Rules
window for the model click on the Scan Prefs tab.
The choice selected above, “Action” indicates that only
when a trade is to be made or a stop is to be set should the
security be listed in the index. The other indexing choices
are generally obvious.

Printing Scan Results
The File menu Print item will cause printing of the scan
results for those securities listed in the index. Other scan
results will not be printed unless you hold down a
“modifier” key....
Hold down the <Shift> key when you select Print and the
content displayed in the Scan Results window will be
printed. Hold down <Alt> (<Option > on the Mac) and all
the scan results will be printed.
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Demo-ing the Scanner
Hitting the Run Scan Demo Now button in the Rule Window, as shown above, will cause SpiffyCharts to
Scan the last twenty bars (if available) of the first data file you opened with the current model. (The “Not Up
To Date” warning will be turned off.)
You should run a demo of the scan on any model you wish to use in your trading and the carefully review the
scanner output in order to understand any limitations the scanner may encounter with your trading model.
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